I get this error message when I open Aldelo after turning my computer on or rebooting it “This POS software requires Aldelo EDC version 6.2 or later. This message will appear if older version of EDC in use or if network communication with EDC server is not able to be attained.”I have Aldelo EDC 6.2 – why am I getting this error message?

A good place to start on a software error would be to go into your control panel into windows and go to your add/remove programs option. Select the Aldelo EDC and choose the option to modify or repair if this does not work we recommend contacting Aldelo or your reseller for further troubleshooting.

Contact Vanguard Systems for your POS Sales and Service
718-921-6159