I get this error message when I open Aldelo after turning my computer on or rebooting it “This POS software requires Aldelo EDC version 6.2 or later. This message will appear if older version of EDC in use or if network communication with EDC server is not able to be attained.”I have Aldelo EDC 6.2 – why am I getting this error message?

This usually happens if the software detects an older version of the EDC that may have been previously installed. If your Aldelo software has been upgraded, the message is probably because there is still that old version info in the registry. your software is still on the newest version but the old info should be removed so you wont get the message.